Показано с 1 по 1 из 1.

Критическая уязвимость выполнения кода в Gnome угрожает Linux-системам

  1. #1
    Administrator Репутация Репутация Репутация Репутация Репутация Репутация Репутация Репутация Репутация Репутация Репутация Аватар для olejah
    Регистрация
    08.03.2010
    Адрес
    Россия, Краснодар
    Сообщений
    11,718
    Вес репутации
    1279

    Критическая уязвимость выполнения кода в Gnome угрожает Linux-системам

    Эксперт обнаружил уязвимость внедрения кода в компоненте обработчика миниатюр в файловом менеджере GNOME, позволяющую хакерам выполнять вредоносный код на компьютерах под управлением систем Linux.

    Уязвимость получила идентификатор CVE-2017-11421, обнаружил ее немецкий исследователь Нильс Дагссон Москопп (Nils Dagsson Moskopp), который опубликовал в своем блоге код, подтверждающий наличие бреши.

    Недостаток присутствует в gnome-exe-thumbnailer - инструменте для создания эскизов исполняемых файлов Windows (.exe, .msi, .dll, .lnk) в GNOME, для этого в системе должен быть установлен Wine.

    Moskopp обнаружил, что при навигации по каталогу, содержащему файл .msi, GNOME принимает имя файла как исполняемые данные и запускает его для создания эскиза изображения.

    Чтобы использовать брешь, злоумышленник может отправить жертве специально созданный .msi-файл, содержащий вредоносный VBScript-код в его имени. Далее взаимодействия с пользователем не понадобится – файл скомпрометирует машину при загрузке.

    «Создается специальный скрипт, содержащий имя файла, для которого нужно показать миниатюру, и выполняется с помощью Wine. Скрипт построен с использованием шаблона, который позволяет вставлять VBScript в имя файла и запускать его» - объясняет Москопп.

    Для эксплуатации этого недостатка хакеры могут использовать и другие векторы атак - например, при подключении USB-накопителя с вредоносным файлом на нем.

    Как защитить себя

    Москопп уведомил об уязвимости как проект GNOME, так и Debian. Они оба исправили брешь в файле gnome-exe-thumbnailer. Рекомендуется как можно скорее установить обновления, уязвимость влияет на gnome-exe-thumbnailer до версии 0.9.5.

    Тем не менее, Москопп также рекомендует:
    • Удалить все файлы в каталоге /usr/share/thumbnailers.
    • Не использовать файлы GNOME.
    • Удалить любое программное обеспечение, которое позволяет автоматически выполнять имена файлов в качестве кода.

  2. Это понравилось:


  3. Будь в курсе!
    Реклама на VirusInfo

    Надоело быть жертвой? Стань профи по информационной безопасности, получай самую свежую информацию об угрозах и средствах защиты от ведущего российского аналитического центра Anti-Malware.ru:

    Anti-Malware Telegram
     

Похожие темы

  1. Ответов: 0
    Последнее сообщение: 19.12.2008, 10:25

Свернуть/Развернуть Ваши права в разделе

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •  
Page generated in 0.01452 seconds with 17 queries