PDA

Просмотр полной версии : Июньский Microsoft Security Bulletin



Shu_b
14.06.2006, 07:23
Microsoft Security Bulletin Summary for June, 2006

Microsoft Security Bulletin MS06-021 - MS06-032

Windows, Internet Explorer: MS06-021, MS06-022
Windows, JScript: MS06-023
Windows, Windows Media Player: MS06-024
Windows: MS06-025, MS06-026, MS06-030, MS06-031, MS06-032
Office, Works, PowerPoint: MS06-027, MS06-028
Microsoft Exchange Server: MS06-029

Примечание: Для загрузки патчей используйте ссылку на статью бюллетеня, из которой выбирайте ссылку на загрузку применительно к вашей ОС или компоненту.

Shu_b
14.06.2006, 07:30
Microsoft Security Bulletin MS06-021
Cumulative Security Update for Internet Explorer (916281)
http://www.microsoft.com/technet/security/Bulletin/MS06-021.mspx
Множественные уязвимости в Microsoft Internet Explorer
http://www.securitylab.ru/vulnerability/268940.php

Rating: Critical

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести фишинг-атаку и скомпрометировать целевую систему.

1. Ошибка повреждения памяти существует пир обработке HTML кода в кодировке UTF-8. Удаленный пользователь может с помощью специально сформированной Web страницы выполнить произвольный код на целевой системе.

2. Ошибка повреждения памяти обнаружена при обработке параметров в ActiveX компоненте DXImageTransform.Microsoft.Light. Удаленный пользователь может с помощью специально сформированной Web страницы выполнить произвольный код на целевой системе.

3. Обнаружена уязвимость в процессе инициализации некоторых COM объектов. Удаленный пользователь может с помощью специально сформированной Web страницы выполнить произвольный код на целевой системе.

4. Уязвимость позволяет удаленному пользователю подменить адресную строку и другие части доверенного UI и произвести фишинг-атаку.

5. Ошибка повреждения памяти обнаружена в процессе сохранения .mht файлов. Злоумышленник может обманом заставить пользователя сохранить злонамеренную страницу в .mht формате и выполнить произвольный код на целевой системе.

Affected Software:
• Microsoft Windows 2000 Service Pack 4
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Affected Components:
• Internet Explorer 5.01 Service Pack 4 on Microsoft Windows 2000 Service Pack 4
• Internet Explorer 6 Service Pack 1 on Microsoft Windows 2000 Service Pack 4 or on Microsoft Windows XP Service Pack 1
• Internet Explorer 6 for Microsoft Windows XP Service Pack 2
• Internet Explorer 6 for Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Internet Explorer 6 for Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Internet Explorer 6 for Microsoft Windows Server 2003 x64 Edition
• Internet Explorer 6 for Microsoft Windows XP Professional x64 Edition
• Internet Explorer 6 Service Pack 1 on Microsoft Windows 98, on Microsoft Windows 98 SE, or on Microsoft Windows Millennium Edition

Shu_b
14.06.2006, 07:36
Microsoft Security Bulletin MS06-022
Vulnerability in ART Image Rendering Could Allow Remote Code Execution (918439)
http://www.microsoft.com/technet/security/Bulletin/MS06-022.mspx
Переполнение буфера при обработке ART изображений в Microsoft Windows
http://www.securitylab.ru/vulnerability/268917.php

Rating: Critical

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке ART изображений. Удаленный пользователь может с помощью специально сформированного AT файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

Affected Software:
• Microsoft Windows XP Service Pack 1
• Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Affected Components:
Windows 2000 with the Windows 2000 AOL Image Support Update installed:
• Internet Explorer 5.01 Service Pack 4 on Microsoft Windows 2000 Service Pack 4
• Internet Explorer 6 Service Pack 1 on Microsoft Windows 2000 Service Pack 4

Shu_b
14.06.2006, 07:41
Microsoft Security Bulletin MS06-023
Vulnerability in Microsoft JScript Could Allow Remote Code Execution (917344)
http://www.microsoft.com/technet/security/Bulletin/MS06-023.mspx
Повреждение памяти в Microsoft JScript
http://www.securitylab.ru/vulnerability/268921.php

Rating: Critical

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Повреждение памяти обнаружено в Microsoft JScript во время освобождения некоторых объектов. Удаленный пользователь может с помощью специально сформированной Web страницы или email сообщения вызвать повреждение памяти и выполнить произвольный код на целевой системе.

Affected Software:
• Microsoft Windows 2000 Service Pack 4
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Affected Components:
• Microsoft JScript 5.1 on Microsoft Windows 2000 Service Pack 4
• Microsoft JScript 5.6 and 5.5 when installed on Windows 2000 Service Pack 4
• Microsoft JScript 5.6 on Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft JScript 5.6 on Microsoft Windows XP Professional x64 Edition
• Microsoft JScript 5.6 on Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft JScript 5.6 on Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft JScript 5.6 on Microsoft Windows Server 2003 x64 Edition
• Microsoft JScript 5.6 on Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Shu_b
14.06.2006, 07:46
Microsoft Security Bulletin MS06-024
Vulnerability in Windows Media Player Could Allow Remote Code Execution (917734)
http://www.microsoft.com/technet/security/bulletin/ms06-024.mspx
Переполнение буфера при обработке PNG изображений в Windows Media Player
http://www.securitylab.ru/vulnerability/268912.php

Rating: Critical

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных во время декодирования PNG изображений. Удаленный пользователь может с помощью специально сформированного PNG файла вызвать переполнение стека и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости злоумышленник должен заставить пользователя запустить злонамеренный WMZ файл или заманить на специально сформированную Web страницу.

Affected Software:
• Windows Media Player for XP on Microsoft Windows XP Service Pack 1
• Windows Media Player 9 on Microsoft Windows XP Service Pack 2
• Windows Media Player 10 on Microsoft Windows XP Professional x64 Edition
• Windows Media Player 9 on Microsoft Windows Server 2003
• Windows Media Player 10 on Microsoft Windows Server 2003 Service Pack 1
• Windows Media Player 10 on Microsoft Windows Server 2003 x64 Edition
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Affected Components:
• Microsoft Windows Media Player 7.1 when installed on Windows 2000 Service Pack 4
• Microsoft Windows Media Player 9 when installed on Windows 2000 Service Pack 4 or Windows XP Service Pack 1
• Microsoft Windows Media Player 10 when installed on Windows XP Service Pack 1 or Windows XP Service Pack 2


Non-Affected Software:
• Windows Media Player 6.4 on all Microsoft Windows operating systems
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems

Shu_b
14.06.2006, 08:06
Microsoft Security Bulletin MS06-025
Vulnerability in Routing and Remote Access Could Allow Remote Code Execution (911280)
http://www.microsoft.com/technet/security/bulletin/ms06-024.mspx
Выполнение произвольного кода в службе RRAS
http://www.securitylab.ru/vulnerability/268930.php


Rating: Critical

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных в службе Routing and Remote Access при обработке RPC запросов. Удаленный пользователь может вызвать повреждение памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в службе Routing and Remote Access при обработке RPC запросов. Удаленный пользователь может вызвать повреждение реестра RASMAN и выполнить произвольный код на целевой системе.

Для успешной эксплуатации уязвимости на системах Windows XP SP2 и Windows Server 2003 требуется валидная учетная запись пользователя. На Windows 2000 SP4 и Windows XP SP1 уязвимость может быть эксплуатирована анонимным пользователем.

Affected Software:
• Microsoft Windows 2000 Service Pack 4
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition

Non-Affected Software:
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Shu_b
14.06.2006, 08:10
Microsoft Security Bulletin MS06-026
Vulnerability in Graphics Rendering Engine Could Allow Remote Code Execution (918547)
http://www.microsoft.com/technet/security/bulletin/ms06-026.mspx
Уязвимость в механизме преобразования изображений в Microsoft Windows
http://www.securitylab.ru/vulnerability/268914.php

Rating: Critical

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при обработке WMF изображений в механизме преобразования изображений (Graphics Rendering Engine). Удаленный пользователь может с помощью специально сформированного WMF файла выполнить произвольный код на целевой системе.

Affected Software:
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Non-Affected Software:
• Microsoft Windows 2000 Service Pack 4
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition

Shu_b
14.06.2006, 08:17
Microsoft Security Bulletin MS06-027
Vulnerability in Microsoft Word Could Allow Remote Code Execution (917336)
http://www.microsoft.com/technet/security/Bulletin/MS06-027.mspx

http://virusinfo.info/showthread.php?t=5545

Rating: Critical

Affected Software:
Microsoft Office 2000 Service Pack 3
• Microsoft Word 2000
Microsoft Office XP Service Pack 3
• Microsoft Word 2002
Microsoft Office 2003 Service Pack 1 or Service Pack 2
• Microsoft Word 2003
• Microsoft Word Viewer 2003
Microsoft Works Suites:
• Microsoft Works Suite 2000
• Microsoft Works Suite 2001
• Microsoft Works Suite 2002
• Microsoft Works Suite 2003
• Microsoft Works Suite 2004
• Microsoft Works Suite 2005
• Microsoft Works Suite 2006

Non-Affected Software:
• Microsoft Word v. X for Mac
• Microsoft Word 2004 for Mac

Shu_b
14.06.2006, 08:23
Microsoft Security Bulletin MS06-028
Vulnerability in Microsoft PowerPoint Could Allow Remote Code Execution (916768)
http://www.microsoft.com/technet/security/Bulletin/MS06-028.mspx
Выполнение произвольного кода в Microsoft PowerPoint
http://www.securitylab.ru/vulnerability/268923.php

Rating: Critical

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Повреждение памяти существует при обработке специально сформированных PowerPoint файлов. Удаленный пользователь может выполнить произвольный код на целевой системе.

Affected Software:
Microsoft Office 2000 Service Pack 3
• Microsoft PowerPoint 2000
Microsoft Office XP Service Pack 3
• Microsoft PowerPoint 2002
Microsoft Office 2003 Service Pack 1 or Service Pack 2
• Microsoft PowerPoint 2003
Microsoft Office 2004 for Mac
• Microsoft PowerPoint 2004 for Mac
Microsoft Office v. X for Mac
• Microsoft PowerPoint v. X for Mac

Shu_b
14.06.2006, 08:28
Microsoft Security Bulletin MS06-029
Vulnerability in Microsoft Exchange Server Running Outlook Web Access Could Allow Script Injection (912442)
http://www.microsoft.com/technet/security/Bulletin/MS06-029.mspx
Межсайтовый скриптинг в Microsoft Exchange Server Outlook Web Access
http://www.securitylab.ru/vulnerability/268932.php

Rating: Important

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в службе Microsoft Outlook Web Access (OWA) во время фильтрации сценариев в email сообщениях. Удаленный пользователь может с помощью специально сформированного email сообщения выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Affected Software:
• Microsoft Exchange 2000 Server Pack 3 with the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup
• Microsoft Exchange Server 2003 Service Pack 1
• Microsoft Exchange Server 2003 Service Pack 2

Shu_b
14.06.2006, 08:34
Microsoft Security Bulletin MS06-030
Vulnerability in Server Message Block Could Allow Elevation of Privilege (914389)
http://www.microsoft.com/technet/security/bulletin/ms06-030.mspx
Повышение привилегий в SMB в Microsoft Windows
http://www.securitylab.ru/vulnerability/268936.php

Rating: Important

Описание:
Обнаруженные уязвимости позволяют локальному пользователю вызвать отказ в обслуживании или повысить свои привилегии на системе.

1. Уязвимость существует из—за недостаточной обработки входных данных в функции "MRxSmbCscIoctlOpenForCopyChunk()" в файле MRXSMB.SYS при обработке некоторых DeviceIoControl запросов. Локальный пользователь может перезаписать память ядра и выполнить произвольный код с повышенными привилегиями на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в функции "MrxSmbCscIoctlCloseForCopyChunk()" в файле MRXSMB.SYS при обработке некоторых SMB запросов. Локальный пользователь может передать функции специально сформированные данные и вызвать отказ в обслуживании системы.

Affected Software:
• Microsoft Windows 2000 Service Pack 4
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition

Non-Affected Software:
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Shu_b
14.06.2006, 08:39
Microsoft Security Bulletin MS06-031
Vulnerability in RPC Mutual Authentication Could Allow Spoofing (917736)
http://www.microsoft.com/technet/security/bulletin/ms06-031.mspx
Подмена данных во взаимной аутентификации RPC в Microsoft Windows
http://www.securitylab.ru/vulnerability/268938.php

Rating: Moderate

Описание:
Уязвимость позволяет удаленному пользователю подменить RPC сервер.

Уязвимость существует при обработке взаимной аутентификации RPC (RPC mutual authentication). Удаленный пользователь может подменить RPC сервер. Для удачной эксплуатации уязвимости опция «использовать SSL для взаимной аутентификации» должна быть включена у RPC клиентов.

Affected Software:
• Microsoft Windows 2000 Service Pack 4 — Download the update

Non-Affected Software:
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Shu_b
14.06.2006, 08:43
Microsoft Security Bulletin MS06-032
Vulnerability in TCP/IP Could Allow Remote Code Execution (917953)
http://www.microsoft.com/technet/security/bulletin/ms06-032.mspx
Переполнение буфера в реализации TCP/IP в Microsoft Windows
http://www.securitylab.ru/vulnerability/268919.php

Rating: Important

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в механизме IP Source Routing в драйвере протокола TCP/IP/. Удаленный пользователь может с помощью специально сформированного IP пакета вызвать отказ в обслуживании или выполнить произвольный код на целевой системе. Для удачной эксплуатации уязвимости IP Source Routing либо служба RRAS должны быть включены на целевой системе.

Affected Software:
• Microsoft Windows 2000 Service Pack 4
• Microsoft Windows XP Service Pack 1 and Microsoft Windows XP Service Pack 2
• Microsoft Windows XP Professional x64 Edition
• Microsoft Windows Server 2003 and Microsoft Windows Server 2003 Service Pack 1
• Microsoft Windows Server 2003 for Itanium-based Systems and Microsoft Windows Server 2003 with SP1 for Itanium-based Systems
• Microsoft Windows Server 2003 x64 Edition

Non-Affected Software:
• Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)