• Необычная уязвимость в Apache mod_rewrite

    В модуле mod_rewrite популярного HTTP-сервера Apache серии 2.2.x обнаружена интересная уязвимость (CVE-2013-1862), позволяющая удаленному злоумышленнику выполнить произвольную команду в момент просмотра лог-файла администратором сервера.
    Уязвимость обусловлена тем фактом, что mod_rewrite при записи в лог-файл не экранирует специальные символы, что позволяет удаленному злоумышленнику, при помощи специально оформленных запросов к веб-серверу, записать туда, например, управляющие последовательности для терминала. При правильном манипулировании такими последовательностями, можно добиться запуска произвольных команд с правами пользователя, осуществлявшего просмотр лога (как правило, подобные лог-файлы доступны для чтения только пользователю root), пишет opennet.ru.
    Доступен патч, исправляющий данную уязвимость. К настоящему моменту проблема исправлена в RHEL и CentOS. Разработчики Debian в курсе наличия уязвимости, однако не считают возможность удаленного запуска команд с правами root серьезной угрозой безопасности («Such injection issues are not treated as security issues»). Разработчики Gentoo также осведомлены о наличии уязвимости, однако пока не предпринимали каких-либо шагов для ее исправления.

    anti-malware.ru
    Эта статья изначально была опубликована в теме форума: Необычная уязвимость в Apache mod_rewrite автор темы CyberWriter Посмотреть оригинальное сообщение
Page generated in 0.00061 seconds with 33 queries