• В DNS-сервере BIND обнаружена критически опасная уязвимость

    Уязвимость в популярном программном обеспечении BIND, используемом для создания серверов доменных имен, позволяет полностью обрушить работу системы и даже затронуть другие сервисы, работающие на том же оборудовании. С таким заявлением в пятницу выступили разработчики из ISC (Internet Systems Consortium), ведущие разработку BIND.

    ISC представляет собой некоммерческую организацию, занимающуюся созданием BIND уже на протяжении многих лет. Здесь сообщили, что уязвимости подвержены только те версии BIND, что ориентированы на работу в Unix/Linux-системах, тогда как Windows-вариант BIND не подвержен данной проблеме, пишет cybersecurity.ru.

    Согласно обнародованной информации, уязвимость кроется по данным разработчиков, в системе обработки регулярных выражений, за которые отвечает библиотека libdns, входящая в BIND. Уязвимы оказываются версии BIND 9.7.x, 9.8.0 - 9.8.5b1 и 9.9.0 - 9.9.3b1. Отметим, что все основные вендоры коммерческих Linux- и Unix-систем в пятницу или субботу уже выпустили экстренные исправления для DNS-сервера.

    По словам специалистов, опасность данной уязвимости заключается в том, что BIND на сегодня является самым популярным DNS-сервером, а для Unix/Linux-систем он вообще является стандартом де-факто. Также BIND используют Solaris, Mac OS X и FreeBSD.

    Уязвимость можно использовать путем отправки специально сконструированных запросов, которые вынуждают демон BIND выйти за пределы отведенной памяти и провоцируют крах сервера с последующим доступом к другим данным на атакуемом сервере. ISC отмечает, что данный баг является критически опасным и ему подвержены как авторитативные, так и рекурсивные DNS-серверы.

    Как сообщили в ISC, если у пользователя нет возможности обновить BIND из новых исходников, доступных на сайте производителя, ему необходимо запретить использование регулярных выражений, вручную отредактировав файл config.h согласно инструкциям, доступным по адресу https://kb.isc.org/article/AA-00879

    Версии BIND 7.x также подвержены уязвимости, но они не исправлены, так как больше не поддерживаются, версии BIND 10.x не подвержены уязвимости, но пока сам разработчик не рекомендует работу с ними на рабочих серверах.

    В ISC уже сообщили, что им известно об атаках на серверы BIND, используемых на реальных серверах. В компании Arbor Networks, оказывающей защиту от DDoS-атак, также говорят об известных им случаях атак и призывают как можно быстрее обновиться.

    anti-malware.ru
    Эта статья изначально была опубликована в теме форума: В DNS-сервере BIND обнаружена критически опасная уязвимость автор темы CyberWriter Посмотреть оригинальное сообщение
Page generated in 0.00192 seconds with 47 queries